BCGE logo
Français

Perturbations BCGE TWINT || BCGE TWINT Service Disruptions || Störungen bei BCGE TWINT

Incident Report for BCGE

Update

We are continuing to investigate this issue.
Posted Jul 03, 2026 - 13:43 CEST

Investigating

--FR-- Notre application BCGE TWINT rencontre actuellement des perturbations. Nos équipes travaillent activement au rétablissement du service.
Nous vous prions de nous excuser pour ce désagrément et vous remercions de votre compréhension.--FR--

--EN-- BCGE TWINT is currently experiencing service disruptions. Our teams are actively working to restore the service.
We apologise for the inconvenience and thank you for your understanding. --EN--

--DE-- Die BCGE TWINT-App ist derzeit von Störungen betroffen. Unsere Teams arbeiten aktiv an der Wiederherstellung des Dienstes.
Wir entschuldigen uns für die Unannehmlichkeiten und danken Ihnen für Ihr Verständnis. --DE--
Posted Jul 02, 2026 - 13:38 CEST
This incident affects: BCGE TWINT.